Zhixian's Tech Blog

2010-09-02

Eclipse Plug-ins (PDE)

Filed under: computing, web application development — Tags: , , , — Zhixian @ 01:33:09 am

This post is about something silly that I did.

This may or may not sound counter-intuitive. I was trying to use a plug-in in Eclipse and I couldn’t get it to install. When I tried, I would get the following helpful message:

An error occurred while installing the items session context was:(profile=PlatformProfile, phase=org.eclipse.equinox.internal.provisional.p2.engine.phases.Install, operand=null –> [R]org.eclipse.cvs 1.0.400.v201002111343, action=org.eclipse.equinox.internal.p2.touchpoint.eclipse.actions.InstallBundleAction). Cannot connect to keystore. This trust engine is read only. The artifact file for osgi.bundle,org.eclipse.cvs,1.0.400.v201002111343 was not found.

Nice. I have totally no idea what is this message talking about. A few googles later, I realise I encounter this because my copy of Eclipse does not have the plug-in development(eclipse-PDE) package installed. I think I may have install Eclipse using the very helpful Ubuntu Software Center. If I have paid more attention, I might have read the following description in the installation package for Eclipse:

This package provides only the Eclipse Platform. It does no include any development plug-ins. These are available in different packages:

  • eclipse-jdt Java Development Tools
  • eclipse-pde Plug-in Development Tools
  • eclipse Complete development environment

This package is the base for all eclipse plug-ins. Please note that many plugins will fail to install if you don’t have the eclipse-pde package installed.

Ahem…
Ah. A beginner’s mistake to be sure.

Here’s the good news. To quickly resolve this issue, just go Ubuntu Software Center and search for eclipse-pde and install it. After you install it, you should be able to install the plug-in that did not get installed previously.

Advertisements

Create a free website or blog at WordPress.com.